
 
 

General Installation 
Notes 

 
Important Information About 

ALERE®  
 
 

 
 
 

ALERE is a mission critical 
application. It is strongly 

recommended that new releases be 
installed on a separate system where 

they can be tested BEFORE being 
released on a live system. 

 
 

Windows XP or later is required to 
operate ALERE. 

 
 

Visit the TIW website at 
www.tiwcorp.com and check for the 
existence of a General Patch. If one is 

available, download and apply it 
before using ALERE. 

 
 

If you have any questions, TIW 
Technical Support would be happy to 

assist you. We may be reached at 
610.258.5161 between the hours of 9 

am and 6 pm ET, Monday through 
Friday, or by email at 

tech@tiwcorp.com 
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PLEASE READ THESE INSTRUCTIONS IN THEIR 
ENTIRETY BEFORE INSTALLING 

Included in this shipment: 

ALERE® CD containing: 

• README.RTF (last minute valuable information) 

• ALERE Program files 

• Runtime files 

• Sample Company Data 

• ALERE HTML Doc-On-Disk  

• Developer’s Source Kit and Manuals (If licensed) 

• Activation Key and Serial Number located on the back of the CD case. 

For new customers: 

• Quick Start Guide     

Managing ALERE’s Program Files and Data 

Starting with v11, each company’s ALERE data files are housed in a single 

directory or Client Server Database.  

DO NOT INSTALL ALERE OVER OLDER VERSIONS 

New versions ALERE must always be installed into an empty directory. 

When installing ALERE for the first time, place the program into a generic 

directory on the server named something like T:\ALERE. This will allow 

administrators to install upgrades by accepting the new directory name and 

changing the path to the server. Always test the installation first by utilizing 

the Sample Company data. We have found that mapped drive letters are 

faster and more reliable than UNC paths. 

When upgrading, rename the old installation to \ALEREVxx and rename the 

new install (\ALERExx) to the original directory name (\ALERE). The startup 

properties on existing workstations will not need to be pointed to a new 

directory using this method. 

After installation, start ALERE. Enter the Activation Key. The sample 

company will automatically be installed if the option was selected from the 

installation menu. If the option was not selected, the user will be taken to the 

Open Company screen, where you create companies.  

We recommend creating a directory like T:\TIWDATA\ with a different 

subdirectory for each company if you have multiple companies. 

Issues with installation for Windows 7 and newer computers. 

If the path to the server cannot be selected on these computers, run 

SETUPLINK directly on the workstations. 

SETUPLINK is automatically written to the server when the Installation Files 

are copied during installation. Alternatively, SETUPLINK may be run from 

the installation CD. 



Updating from ALERE v11 and later: 

1. Copy wsalere.*, wsaccess.*, wscldusr.*, ws_lingo.*, and wslogins.* to the new ALERE sysfiles 

directory. 

2. If the ALERE installation has been modified, please follow the instructions outlined in the Installation 

and Migration of ALERE Modifications subsection to port the modifications to the new version. 

3. The TIW File Update utility must be run for each company after migrating the data and modifications. 

(File > System Tools > TIW FILE UPDATE) 

4. Ensure users have full administrator rights to the data and sysfiles directories. 

 

Updating with CS Data 

Copy the subdirectories with your databases’ names to the new install. 

 

Updating from ALERE Manufacturing v10 and Accounting 7.3 or earlier: 

Before getting started: 

• If utilizing both ALERE Accounting and Manufacturing, the data contained in the previously independent 

wslogins and wsaccess files will need to be merged (not copied.) Ensure there are no duplicate 

records. The wslogins.* and wsaccess.* files have been relocated to the Sysfiles directory. 

• wslogins.*. This file contains ALERE’s user logins. If utilizing both Accounting and Manufacturing, it is 

easier to copy from whichever package contains the most user logins and simply add any additional 

users as required. Note that user rights now apply to both Accounting and Manufacturing. Records may 

need to be edited on a user-by-user basis. These files may be merged. However, ALL user rights will 

need to be reviewed and updated. Within the table is a memo field PWCANDO containing exceptions to 

the basic right. If a user has limited rights, it is possible to manually merge the data in this field for users 

with access to both Accounting and Manufacturing directly in the database. 

• wsaccess.*. This file limits what companies users may access. It is best to simply copy the table which 

contains the most information. Afterward, edit and append the user permissions as necessary. Note 

that this table will be blank if there is only one company or if all users can access all companies.  

Create new companies when migrating from older versions: 

When migrating from versions prior to v11, it is REQUIRED to manually create new companies as numerous 

data structures have changed as of v11. 

1. Open the existing ALERE Accounting and/or ALERE Manufacturing Company Defaults screens to 

serve as a reference. 

2. Open the ALERE program and navigate to File > Open Company. 

3. Click “New” to display the New Company screen on the Open Company screen. 

4. Check the boxes for importing ALERE Accounting and/or Manufacturing data. 

5. Enter the paths to the Accounting and Manufacturing company data which are being migrated. 

6. Enter the company name and a new company data path. THE DATA PATH MUST NOT BE THE 

SAME AS THE OLD ONE. A LAN or Client Server company may be created by selecting the 

appropriate database type. If desired, a CS company may be created from a LAN company at this 

stage. (Running with Client Server data requires installing Microsoft SQL Server before setting up the 

companies.) 

7. Press the “Continue” button. 

8. Enter the company setup information, referencing the previous installations. 

9. Click “Save” then “Exit.” The File Update screen will be displayed. Run the utility for “All Tables.” 



10. Repeat for additional companies. Each company must have its own data directory or, for CS 

installations, its own database. If linking ALERE Mfg to other accounting packages, the ALERE data 

MUST reside in a different data directory or database than the linked accounting package.  

11. If the ALERE installation has been modified, please follow the instructions outlined in the Installation 

and Migration of ALERE Modifications subsection to port the modifications to the new version. 

12. Ensure users have full administrative rights to the data and sysfiles directories. 

Installation and Migration of ALERE Modifications 

Notes before beginning the process: 

If migrating modifications from version Manufacturing v10, Accounting v7.3, or earlier 

• ALERE versions after Accounting v7.3 and Manufacturing v10 have changed the size of almost every 

screen. Review all screen modifications and adjust to fit the new screen size. 

• Data from the older versions of usrtable.* and usrpaswd.* must be appended into the current tables. 

Do not replace these files. 

• Append the records from the newly created ws_lingo for TYPE = "Ribbon.” Copy to the new ALERE 

installations Sysfiles directory. 

If migrating modifications from v12 or earlier: 

• Please note that as of ALERE v12, the fields “Street 1” and “Street 2” have been merged into a single 

memo field.  

• Any screens or reports which have been modified and utilized this information must be updated. 

If migrating modifications from v14 or earlier: 

• Any screens or reports that have a tax field need to be updated due to the tax changing from a logical 

field to a character field. 

Setup and Installation of Modifications 

If ALERE has been modified, it is very important to install and test modifications on either the sample 
company or a test company prior to using them in a live company. 

All modifications, custom programs, and reports should be placed in a “MODS” directory directly under the new 

ALERE root directory. 

1) Create a “MODS” directory in the root of the new ALERE installation. 

2) Open the new installation of ALERE, select the test or sample company, and navigate to File > 

Maintenance > Company Defaults > Default Paths and ensure the path to the “MODS” folder is 

correctly defined for each company. 

3) Copy all custom programs, VAR files, and/or reports from the old ALERE installation to the new 

“MODS” directory. 

4) If the ALERE installation has modifications that include the change of field size, or other modifications 

to any system file, copy the following tables to the new sysfiles directory: usrdata.*, usrffdef.*, 

usrindex.*, usrmap.*, usrtable.*, and usrribbn.*.  

5) Append existing data to usrpaswd.* do not copy! 

6) If modifications included changes to wshooks.dbf:  

a) Open the table, delete any records which do not pertain to the modifications, and copy the file to the 

new sysfiles directory. 

7) It is good practice to place copies of the current USR files in this directory or a subdirectory. 

8) TIW File Update must be run for each company after installation of the modifications.    

(File> System Tools> TIW FILE UPDATE) 



9) Consult the Developers Kit readme files for additional information on what areas of the product have 

changed. 

10) Carefully test all modifications before moving them into the live company within ALERE. 

Special Note Regarding Runtime files: 

ALERE requires specific Runtime, OCX & DLL files to operate. When upgrading from a version earlier than 

ALERE v11, select the option to install the Runtime during installation. All workstations must be updated. 

Ensure you are logged in as the local administrator for Windows or as the network administrator on the server 

when installing or upgrading ALERE. 

Special Note Regarding Runtime files for Manufacturing linked to Pro Series: 

ALERE requires specific Runtime, OCX, and DLL files to operate. If Pro Series runtime files are installed, 

replacing them with the same named files from ALERE will be necessary. Pro Series will run on ALEREs 

runtime, but ALERE cannot run on Pro Series runtime. The specific files in question are VFP9R.DLL and 

VFD9RENU.DLL. Perform a search for these files on each workstation. DELETE all the copies found, and 

COPY the same files from the ALERE CD to the SAME locations. 

Special note for Remote Desktop/ Terminal Server Installations: 

It is no longer necessary to have a separate TIWRUN directory for each user. Simply point all users’ shortcuts 

to the same TIWRUN directory on the terminal server. Note that on a traditional network, the TIWRUN 

directory should still reside on the local drive so that users can access the manual.  

HTML Manual Installation: This should be completed and TESTED on ALL workstations! 

A Microsoft Security rule sometimes prevents .chm (compiled HTML files) from being viewed when loaded 
from a network drive or remote server.  

 

 Note: The manual must be on the local drive! 

 

If the HTML manual cannot be viewed when the “?” button on a screen is selected, then follow these 
instructions: 

1. Start the program and go to File > Maintenance > Company Defaults > Options. 

2. Select the Use “HTML Help” and “HTML Manual on Workstations” options. 

3. Save the change, exit the screen, and restart ALERE. The workstation will automatically download the 

manual from the server for local use. Thereafter, the manual will automatically be updated whenever 

the manual on the server is updated, and ALERE is opened on the workstation. 

4. Start the manual directly from a desktop shortcut. When the run dialogue appears, uncheck “Always 

ask before opening this file” and select “Open” or “Unblock” to view the file. 

5. Verify that the contents and index are shown on the left side of the screen. If they are not displayed, 

click the “Show” button at the top left of the screen. If the screen does not contain that button, hover the 

cursor over the bar just inside the left edge of the screen and drag to the right. 

The Help Manual should work from the desktop shortcut or within ALERE. 

The Help Manual is periodically updated on our website. Please sign up for TIW’s notification service list to 

receive an email when a new version of the manual is available. When notified, download the new manual from 

the TIW website and place it in the ALERE directory on the server. The updated manual will automatically be 

distributed to workstations when ALERE is started. 


